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Overview 
Current method of accessing the directory  

Mithi Connect Server stores the corporate user directory on the server and makes it available via the LDAP 
interface.  You can access this directory by  

Using the address book interface of the Mithi web client 

Or 

By configuring the LDAP directory in the desktop email client (Outlook, Outlook express) 

Accessing the LDAP server directly from the desktop clients has the following 
limitations: 

• The address list is not accessible, if the connectivity to the server is not available.  

• The bandwidth required for the LDAP protocol is high i.e. every lookup or search will require the 
desktop client to connect to the server. 

• Configuration of the LDAP directory in Outlook is not easy and is prone to errors. 

• The usability of this solution is poor when compared with the proprietary integration of Outlook with an 
Exchange backend e.g. Outlook does not display the list contacts stored in the LDAP directory making 
the selection of contacts a little cumbersome. 

 

What’s required: an Address Book that is easily accessible from anywhere 

All end users on a mailing & collaboration system need to be able to easily access the contact information of 
their colleagues and other associates in the company. 

Solution: Mithi’s Desktop Address Book (providing easy and offline access to the 
corporate directory) 

The Desktop Address Book (DAB) add-on module for Mithi Connect Server addresses the above 
challenges.  
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The Desktop Address Book (DAB) is a Windows application installed on every user's desktop, and has the 
following key features:  

Off line access: 

• Periodically or on demand the DAB synchronizes with list of contacts on the server and stores it on the 
users desktop. 

• This list of contacts stored on the users desktop is then accessible via the address book interfaces of 
Outlook & Outlook express without having to connect to the server. 

Easy and automatic Address book definition: 

As a major improvement over the older method of defining site & group specific address books in a system 
like MS Exchange, the Mithi DAB automatically generates views based on selected fields in the directory. 
E.g. if we configure DAB to show views based on Company & Office, then it will generate address books 
based on unique values of company and within that office. A sample view is shown below: 

All <domain> contacts 

   Company 1 

                      Office 1 

Office 2 

                 Company 2 

                      Office A 

Selecting Company 1 will show all users from Company 1. Selecting Office 1 will show all users from this 
office of Company 1.  



 

Mithi Connect Server™ - Desktop Address Book Version 1.0.2.32 
Copyright © 2000-2008 Mithi Software Technologies Pvt. Ltd. 

• This method completely eliminates the need, by the administrator, to define separate address books for 
each site/group, saving an enormous amount of time and effort. 

• The views have a standard look and feel. Selecting a view (company or office) from the interface shows 
the address book, pertaining to the company or office. 

• Users can select different views as default from the Outlook options  

• The fields and hierarchy for the views can be defined by the administrator for a domain. 

Smooth Interface: 

• The fields for each contact are shown in a pane with separate columns. 

• Selecting a contact from the address book view, opens up detailed properties of that user. If this contact 
is a group, the details also contain the list of group members. 

• Users can Search for contacts, by display name, in the address book window.  
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Getting started 
This document explains the working of the DAB client installed on the Windows desktop. The document 
covers, installation, configuration and working of DAB with email clients Outlook and Outlook Express. 

A trouble shooting section in the end highlights the key problems faced when installing / working with DAB 
and their solutions. 

To install, configure and use the DAB, do the following 

1. Download and install the Desktop Address Book application. 

2. Configure the Desktop Address Book application. 

3. Close Outlook and Outlook Express applications. 

4. Using the right click menu of the application, update the address book. 

5. For Outlook clients: 

a. Depending on the client, configure the DAB connector to upload the address book to the 
desktop email client. 

b. Start Outlook. 

c. Enable Address lookup. 

6. For Outlook Express client, follow the steps given in the section on Outlook Express. 

The details for the above steps are given in the sections below. 

System Requirements 
Operating System: Windows 2000 SP2, Windows XP SP2, Windows XP SP3, Windows XP 64 bit, 

Windows Vista 

Desktop Email Clients:  MS Outlook 2000*/2003/2007 

Outlook Express 6.0 

RAM:    256 MB+ 

Installation 
1. Copy the install folder to the client machine. 

2. Run setup.exe from the install folder. 

3. This will launch the Welcome page of the installer. To start installation, click on Next button 
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4. The next page will show the license Agreement for DAB. Click on the I Agree button to proceed. 
Clicking on the Cancel button will stop the installation. 
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5. The installation now starts. The next screen will show the progress. All the buttons on this page are 
grayed till the installation is in progress.  
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6. Once the installation is complete, the DAB application is launched with the User Info tab selected. Here 
you have to enter user information. Such as user id, domain, the IP of the mail server from where the 
address book is to be downloaded, etc. The information to be filled is as follows: 

a. User – The email id has to be given here. 

b. Domain – The domain configured. 

c. Server – This is the IP of the MCS server from where the address book has to be 
downloaded to the client’s machine. Please contact your system administrator for the IP to 
be configured. 

 

If you are using a proxy server, then the section on the Proxy has to be filled.  

Fill in the relevant information and click on the OK button. This will take you back to the setup 
application. 

7. Click on the Finish button to complete installation.  
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8. Once the installation is successfully completed, the a yellow icon will appear on the toolbar as shown 
below. 
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Configuration 
As mentioned earlier, the DAB consists of two major components, one is the Downloader, which downloads 
the address book from the MCS server and second is the Outlook/Outlook Express Connector which 
converts the address book into a format recognizable by the desktop email client. 

The configuration of both these components is done via the DAB Configuration application. To launch the 
DAB application, double click on the icon that appears after the setup is complete, as shown below. 

 

User Information tab 

By default, the User Information tab is shown. The User information tab will show the user id, domain and 
IP address of the server configured. The application connects to the server using this information. Using the 
User Information tab, you can also specify proxy authentication information. For more information on how 
DAB works with a Proxy server, refer to the Appendix. 

 

 

Client Information tab 

The Client information tab should be used to inform the DAB about the desktop email client being used. All 
the clients supported by DAB will be available on the page. The current version of Desktop Address Book 
supports the different versions of Microsoft Outlook clients and Outlook Express. Select the appropriate 
client. You may select both if required. 
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The Add email id in Display Name option can be used when you do not want the email id to be shown in 
the first column of the address book listing or on auto-complete. 

In the Troubleshooting section, clicking on the Recover Outlook Express Address book will revert to the 
last good state of the address book. This option can be used to recover the address book after an Outlook 
Express crash. 

 

 

Desktop Address Book data tab 

You can configure automatic update of the address book from the server using the Enable scheduled 
update of address book option on the Desktop Address book data tab. 

On selecting the option, you can customize the schedule as per your requirements. The schedule can be 
Daily, Weekly or Monthly. If you choose Weekly, then you have to specify the day of the week. If you 
specify monthly then you can specify the day of the month. 

Whether you choose Daily, Weekly or Monthly, you can specify the time of the day when the update is 
scheduled using the Set the time of the day when you want to start the update option. 

In addition to the scheduled updates, you can sync the address book from the server by clicking on the 
Update Address Book now button. 
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Maintenance tab 

The options on the Maintenance tab are used to configure the logging system.  Logs are required to 
troubleshooting problems in downloading etc. 

The path in the Store Folder is the path where the configuration file, log files etc are stored. To change the 
default path, give the new path and click on the Set Store folder button. 

You can turn logging on or off by the ON and OFF options in the Logging section. 

The log level can be customized to Debug, Info, Warning or Fatal level by selecting the corresponding 
option in the Log Level section. The description for the log levels are as follows: 

Debug:  Enables heavy traces. 

Info:  Logs operation calls, warning and errors. 

Warning: Logs temporary failures and errors. 

Fatal:  Logs only failed operations. 

Every day the log file is backed up and a new log file is used to collect the logs. This helps in keeping the log 
file size to a minimum. The Days to keep log files in history setting in the Log history section allows you 
to specify the number of days for which the logs have to be maintained on the PC. 
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Right click menu 

Right clicking on the application will pop up a menu with the following options 

1. Update: this option allows you to download the address book now. 

2. Properties: launches the application 

3. Help: will open this document. 

4. About us: will open the Mithi site. 

5. Exit: Will exit the application. 
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DAB Outlook Connector – uploading the address book 
in Outlook clients 
Outlook 2000 

To configure the DAB Outlook Connector in Outlook 2000, follow the steps given below: 

1. From the Control Panel invoke the Mail applet 

 

2. Select Outlook Address Book. Click on the Add button. This will load the Add Service to Profile dialog 
box. Select Mithi Connect Server Address Book from Available information services. Click on the 
OK button. 
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3. The profile Properties dialog box will now show the Mithi Connect Server Address Book service 
selected. Click on the OK button. 
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Outlook 2003 

To configure the DAB Outlook Connector in Outlook 2003, follow the steps given below: 

1. From the Control Panel invoke the Mail applet 

 

2. Click on E-mail Accounts button 

 

3. Select Add new directory or address book and click on the Next button. 
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4. Select Additional Address Books and click on the Next button. 

 

5. From the list of Additional Address Book Types list box, select "Mithi Connect Server Address Book". 
Click on the Next button. 
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6. When prompted, click on the Finish button  

7. Close the Mail Setup Dialog box. 

Outlook 2007 

To configure the DAB Outlook Connector in Outlook 2007, follow the steps given below: 

1. From the Control Panel invoke the Mail applet. 

2. On the Mail Setup – Outlook dialog box, select E-mail Accounts … button. 
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3. In the Account Settings dialog box, select the Address Books tab. 

4. Click on the New icon. 

 

 

5. In the Add New Email Account dialog box, select Additional Address Books. 
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6. In From the list of Additional Address Book Types, select Mithi Connect Server Address Book. 
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7. Click on Next and the Finish button. 

Enable address lookup in Outlook 
1. Run MS Outlook 

2. From the Tools menu, select Address Book… 
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3. In the Address Book dialog box, choose Options … from the Tools menu. 

 

 

4. On the Addressing dialog box that shows up, click on Add 
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5. From the Add Address list dialog, choose the Default Address Book List from the and click on Add 
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6. This will load the Add Address List dialog box. This dialog box will show all the address lists available. 
There will be an All Addresses list and one for each view defined. For example, for a multi-location 
setup, where the views are defined using the mailbox location, there will be one list per location. Select 
the list. 

7. Click on Close. This will add the address list to the list of addresses in the When sending mail, check 
names using these address lists in the following order list box. 

8. The setting in the When sending mail, check names using these address lists in the following 
order determines the address lists used to auto-complete an address when you press Cntrl+K. If you 
want the system to refer to your local contacts first, then do not change the order. If you want to refer to 
the address list loaded by the Dab first, then change the order. 

9. To set the default address list, select the address list from the Show this address list first box.  This is 
the list which will be shown when you click on the TO/CC etc buttons when composing a mail.  
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10. Note: Though you can select two different lists in the Show this address list first and the When 
sending mail, check names using these address lists in the following order, it is recommended 
that the same address list is selected for both so that the list used for auto-complete and the list shown 
are the same. 

11. Close the address book application. 

12. Note: If Outlook finds a match in the local contacts, it does not check the remote address books. Refer 
Appendix for the work-around provided by Microsoft  
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Using the address book 
From the compose message window you can open the address list by clicking on To/Cc/Bcc buttons. 
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To auto-complete address in the To/Cc/Bcc box, type a part of the address and press Ctrl + K. If Outlook 
finds a single match then the address is completed. In case multiple addresses are matched the Check 
Names dialog is opened. You can access the entire list by clicking on the Show More Names… button 

 

Checking recipient names before sending a message 

Before you send a message, Microsoft Outlook automatically checks the names you type in the To, Cc, and 
Bcc boxes against the names in the Address Book and against those contact folders that you've specified as 
Outlook Address Books. If an exact match is found, the name is underlined. If multiple matches are found, a 
red, wavy line appears under the name. Right-click the name to see the matches. 

If multiple matches are found, and you have used the address before, the name you chose previously is 
displayed in the box with a green, dashed underline to remind you that there are other matches. Right-click 
the name to see the matches. 

You can also manually check names in messages by clicking the Check Names button on the message 
toolbar. 

1. To start automatic name checking: 

a. On the Tools menu, select Options. On the Preferences tab, select the E-Mail Options 
button. In the Message handling section, select the Advanced E-Mail Options. Button 

b. In the When sending a message section, select the Automatic name checking option.  

 



 

Mithi Connect Server™ - Desktop Address Book Version 1.0.2.32 
Copyright © 2000-2008 Mithi Software Technologies Pvt. Ltd. 

 

 

2. Turn on automatic completion of e-mail names 

a. When sending a message, Type in the first alphabet and use control + k  

b. A list of contacts with similar initial will appear. 

c. Check/select the required  names while completing To, Cc, and Bcc fields check box. 

3. Find names in the Address Book dialog box 

a. On the Tools menu, click Address Book.  

b. In the Show names from the list, click the address book you want to search for names.  

c. In the Address Book dialog box, on the Tools menu, click Find, and then type the name for 
which you are searching.  
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Notes  

• Depending on the address book you select from the Show names from the list, you can type 
additional search information in the Find dialog box, such as the person's alias or department 
name.  
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DAB for Outlook Express 
To configure the DAB Outlook Express Connector, select the Outlook Express option on the Client 
Information tab of the Downloader configuration. 

For Auto-complete: 

a. Run Outlook Express  

b. From the Tool menu, select Options 

c. Click on the Send tab 

d. Turn off the "Automatically complete email addresses while composing" option 

 Reason: When this option is on, OE inserts the first email address matching the typed substring. 
 The other contacts are not listed from Address book. 

e. Press OK to the save the configuration. 

  

 

Composing a mail 

a. Run Outlook Express 

b. From the File menu choose New - Message 

c. In the To box, enter the partial name of the recipient  
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d. Press Ctrl + K to complete the address 

e. If there are multiple addresses matching the partial string then a pop up box is shown with list 
of the matched email address 

 

f. Select the desired addresses and press ok. 

 

Viewing the Address book 

1. Run Outlook Express 
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2. From the Tool menu, Select "Address Book" 

 

3. In the Address book application, select "Shared Contacts" from the left pane. 

4. The Addresses will be listed in the right Pane. 

 

Limitations 

1. It needs IE 6.0 to be installed. 

2. The desktop machine should have at least 256 MB of RAM. When synching the address book 50-100 
MB of RAM is used. 

3. The download and sync will take about 30 minutes, during which clicking on the DAB icon will give no 
results. 
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Compare Exchange and MCS behavior 
The current beta version of Mithi Connect Server Address book connector does not  

1. Show or highlight users, groups and contacts separately. 

2. Sort the user list on the fields shown in the Address list  

3. Show personal information details for a user 

4. Automatically add the Address book to the "Search for names in address" list 

Troubleshooting 
The address book is not getting updated 

Please ensure your outlook client is closed. Update the address book and re-launch the Outlook client to 
use the updated address book. 

The address book is not working for a Windows user with limited access rights 

For a user with limited access rights the data folder of DAB will have to be changed. The new store folder 
should have read and write permissions for the user. Refer Appendix D for details. 

Which files should i send to mithi support to debug client problems 

• C:\Program Files\mithi\address book\logger\mcsabconf.log<br> 

• C:\Program Files\mithi\address book\downloader\conf\abdownload.inf<br> 

• C:\Program Files\mithi\address book\data\Address_Book.csv<br> 

• C:\windows\mithiab.ini 

I am getting a transient error while downloading the address book 

DAB required BITS service running properly on the client machine this is the same service used by the 
Windows Update. Check if your Windows Update is working properly on the machine. 

• Open Windows Control Panel 

• Select System 

• Click on Automatic Updates tab 

• Select either Automatic or Download updates for me, but let me choose when to install them 

• Press ok 

• Check if windows update is working 

• If not refer to Troubleshooting Windows Update on microsoft's site. 

Workaround 

On the server perform the following steps: 

• cd /mithi/mcs/modules/mithi-mailclient/user/pl/webapp/webroot/addressbookdb/<domainname>/global 

• cp Address_Book.csv.gz /tmp 

• gunzip /tmp/Address_Book.csv.gz  

• cp /tmp/Address_Book.csv.gz Address_Book.csv 

• chmod 644 Address_Book.csv 
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On the client perform the following steps 

• Open your browser 

• In the address bar type: http://<server ip>/addressbookdb/<domainname>/global/Address_Book.csv  

• Save the file on client machines C:\ 

• copy the file to the DAB store folder 

Finding where is your DAB store folder 

• From the Windows Start menu open the Run dialog 

• Type cmd and press enter 

• run the command: find "PATH" %WINDIR%\mithiab.ini 

Check if there is a  firewall with access control to server ip 

• Open Internet Explorer 

• In the address bar type  http://<servername>/addressbookdb/<domainname>/Address_Book.csv 

• The file should be downloaded 

Recommended Solution 

• Add <serverip> as a trusted site in your firewall or Proxy. 

Check if multiple extension downloads are blocked 

• Open Internet Explorer 

• In the address bar type  http://<servername>/addressbookdb/<domainname>/Address_Book.csv 

• The file should be downloaded 

• If the Step A failed and this worked then either files with gz extension are blocked  

Or 

• Files with multiple extensions (.csv.gz) are blocked. 

Recommended Solution 

• Add <serverip> as a trusted site in your firewall or Proxy. 

• Allow files with multiple extensions and gz extension for this site 

Check if client account has rights to run a BITS job 

• Does user have administrator rights 

If not 

• Is the user a standard (Power) user  

• Is the user a restricted user 

Recommended Solution  

• Minimum the user should be a Power User. 

How do I check if Background Intelligent Transfer Service  is installed 

On the Start menu, click Run.  



 

Mithi Connect Server™ - Desktop Address Book Version 1.0.2.32 
Copyright © 2000-2008 Mithi Software Technologies Pvt. Ltd. 

In the Run Dialog box, type services.msc and then click OK.  

In the list of services, find Background Intelligent Transfer Service 

How do I check if Background Intelligent Transfer Service is enabled 

On the Start menu, click Run.  
In the Run Dialog box, type services.msc and then click OK.  
In the list of services, find Background Intelligent Transfer Service 
click Properties.  
The Startup type should show Manual/Automatic 

How do I check if BITS interfaces are not registered or the registry settings are 
corrupted and repair them 

Run the command  

On the Start menu, click Run.  
type cmd and press enter 

Run the command 

Bitsadmin /util /repairservice /force 

How do I check if BITS is able to download from the client machine 

From the windows command prompt, run the commands 

mkdir c:\tmpdownload 
bitsadmin /transfer myDownloadJob /download /priority normal http://<server ip>/index.html 
c:\tmpdownload\index.html 

How do I check if Is DAB Downloader initialised 

1. Double click on the Mithi DAB(Yellow )icon on the System Task bar 

2. Click on the Maintenance Tab 

3. Copy the Store Folder path and open it using the Windows Explorer 

4. Open the logger folder  

5. The log file is  
Find "BITS Initialisation failed error code:" 

Autocomplete behavior in Outlook 2003 and Outlook Express 

On Outlook 2003 after typing part of the address/firstname/lastname one needs to press Ctrl + K to get the 
list of contacts which match the sub-string. The Contact is matched if the substring forms the part of the 
display name. 

On Outlook express the auto complete lists addresses which start with the typed string. To lookup for a 
substring the user needs to press Ctrl + K 

A address is not auto completed even though is in though it is in the address list 

a. Is the address present in the views selected for auto complete 

Select a Address view common to both the address lists for auto complete 

Refer: Enable address lookup in Mithi Connect Server Address Book. (Outlook 2000 and 2003) 
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b. Does the substring match with a address in another address list selected for auto complete 

Select a Address view common to both the address lists for auto complete 

Refer: Enable address lookup in Mithi Connect Server Address Book. (Outlook 2000 and 2003) 
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Appendices 
Appendix A: Work-around provided by Microsoft - To specify the address provider in 
a message without changing the order 

To specify the address provider in a message without changing the order, follow these steps:  

1. On the File Menu, click New, and then click Mail Message. Click to place the cursor in the To, CC, or BCC 
field, and type an e-mail address.   

2. If you want to force the address to be resolved from the GAL, type an EQUAL SIGN (=), or if you want to 
force the address to be resolved from Contacts, type a MINUS SIGN (-). 

NOTE: When you use this method, make sure to type a space between the EQUAL SIGN (=) or the MINUS 
SIGN (-), and the alias that you intend to resolve.  

3. Type the recipient name, or Microsoft Exchange Server alias for the recipient immediately after the 
character chosen in step 2.  

4. Repeat the process for all other recipients and then send the message.  

The address provider order will be overridden for the message currently sent, but this does not make a 
permanent change to the order specified using the steps in the "To Change the Address Provider Priority" 
section. 

Appendix B: Work-around provided by Microsoft - To Change the Address Provider 
Priority 

To view and change the address resolution priority, follow these steps:  

Outlook 2000 

1. On the Tools menu, click Services.  

2. In Services, click the Addressing tab. The address list priority is displayed in the When sending mail, 
check names using these address lists in the following order list.  

3. To permanently change the address list priority, click an address provider and then click the arrows to 
arrange the address providers in the order you want to have addresses resolved.  

Outlook will resolve the name to the first address it matches based upon the address order. 

Outlook 2003 

1. On the Tools menu, click Address Book 

2. In Address Book Application, from the Tools menu choose Options. The address list priority is displayed 
in the When sending mail, check names using these address lists in the following order list.  

3. To permanently change the address list priority, click an address provider and then click the arrows to 
arrange the address providers in the order you want to have addresses resolved.  

Outlook will resolve the name to the first address it matches based upon the address order. 

Appendix C: How DAB works via Proxy. 

The Address book downloader uses the BITS download service to update the address book. 

By default BITS first tries to connect to the server directly. If this connection fails it tries to connect 
to the server via the proxy server. The Proxy server and Port information is retrieved from the IE 
configuration. BITS attempts a unauthenticated access via the proxy. If this fails, it uses the 
Authentication information provided on the DAB User information configuration page. 
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You can also by pass the use of proxy by un-checking the Use proxy during address book 
information download.  

 

Appendix D: How do I change the data folder of DAB? 

1. Double click on the DAB icon on the system tray to launch the DAB address book 
configuration dialog 

2. Click on the Maintenance tab 

3. Click on the Set Store Folder button 

4. A Browse for folder dialog will pop up. Choose the folder for storing DAB data. You can 
create the folder using the Make New Folder button. 

5. Click on OK 

6. Click on OK to the apply the configuration and close the DAB configuration dialog 

7. Restart DAB 

8. If MS Outlook is running, restart MS Outlook. 
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